Back to overview
Degraded
DDoS Attacks
Mar 15 at 01:49am GMT
Affected services
Banana
Resolved
Mar 15 at 02:48am GMT
Resolved.
Affected services
Banana
Updated
Mar 15 at 02:42am GMT
Our upstream provider has mitigated the congestion, EU players should be fine to play again.
Affected services
Banana
Created
Mar 15 at 01:49am GMT
Our provider is currently under an immense DDoS attack that is causing upstream congestion for EU players, resulting in disconnections and timeouts.
Affected services
Banana