Back to overview
Degraded

DDoS Attacks

Jul 10, 2023 at 6:20pm UTC

Resolved
Jul 10, 2023 at 8:30pm UTC

Resolved

Updated
Jul 10, 2023 at 7:25pm UTC

We've mitigated the attack and are monitoring for improvements.

Created
Jul 10, 2023 at 6:20pm UTC

We're currently experiencing a DDoS attack that is impacting our main server in NA.