Back to overview
Degraded

CDN Connection Issues

Jan 30 at 07:12pm GMT
Affected services
Cloudflare

Resolved
Jan 30 at 08:13pm GMT

After adding a temporary change, we've managed to get the CDN into a 'fine' state.

Downloads are normal again, for now...
This may happen again in the future unless Cloudflare can resolve the issue.

Created
Jan 30 at 07:12pm GMT

We are currently experiencing (what looks like, anyway) a DDoS attack towards our CDN, directly impacting players in-game and those who are connecting on both servers.

A ticket has been opened and we are awaiting a response.