Back to overview
Downtime

Global outage for FiveM

Oct 18 at 10:00pm BST

Resolved
Oct 19 at 12:20am BST

The issue was identified and a fix has been implemented.

Created
Oct 18 at 10:00pm BST

Players from all regions are currently experiencing connection issues due to an incident with our provider. This is out of our control to resolve, but we'll update this status report as we learn more.